Fylgist með skrám og vinnur úr þeim

Vakta fylgist með skrám sem uppfylla tiltekin skilyrði og vinnur úr þeim. Það hentar sérstaklega fyrir sjálfvirkt gagnaflæði milli ólíkra tölvukerfa. Forritið vinnur eftir vaktskilgreiningum í skránni Vakta.mdb sem er Access 2000 gagnagrunnur. Vaktskilyrðin og skýrslugluggi birtast á skjánum, sem auðveldar notendum að fylgjast með framvindu mála.

vakta1

Ýmsir valkostir eru í boði til að auka sem mest sjálfvirknina:

· Flytja skrá fyrir vinnslu í annað skráasafn
· Breytur fyrir skrárheiti eða einstaka hluta þess
· Val um að birta glugga úrvinnsluforrita ýmist í forgrunni eða bakgrunni eða alls ekki
· Sjálfvirk vöktun (frá 5 sekúndna til 60 mínútna fresti)
· Heldur utan um síðustu skrár sem unnið var úr og hvenær það var gert
· Heldur utan um fjölda skráa sem fundust

Úrvinnsluforritin geta verið af ýmsum toga, t.d. hefðbundin Windows forrit, skipanalínu-forrit og BAT-skrár. Þau eru ábyrg fyrir því að eyða skránni eftir vinnslu, ef hún er ekki flutt í sérstakt vinnusafn áður.


Innsetning

Til að setja forritið upp á tölvunni þinni, er auðveldast að vinna Vakta_setup.exe. Það setur inn viðeigandi skrár og stillir einnig upp gagnagrunnsvinnslu fyrir Access-töflur ef hún er ekki þegar uppsett á tölvunni þinni.

Einnig má flytja forritið handvirkt milli tölva. Þú þarft aðeins að afrita 3 skrár (Vakta.exe, Vakta.mdb og Vakta.chm) þangað sem þú vilt geyma forritið og búa til flýtivísun á Vakta.exe. Allar stillingar forritsins eru geymdar í System Registry (undir lyklinum HKEY_CURRENT_USER\Software\Hugmót\Vakta) og gagnatöflunni Vakta.mdb.


Notkunarskilmálar

Sýniseintök af þessu forriti eru ókeypis og má dreifa því mjög frjálslega. Nýjustu útgáfu getur þú sótt á slóðinni www.hugmot.is/vakta. Ef þú sendir öðrum forritið, skaltu dreifa skránni Vakta_setup.exe, eða vísa þeim á vefinn, því hún inniheldur forritið, gagnagrunninn og hjálpartextann.

Sýniseintök eru takmörkuð við 3 virk vaktskilyrði, en skráð eintök hafa enga slíka takmörkun. Þú getur pantað skrásett eintak á vefnum www.hugmot.is/vakta/skraning og lagt okkur þannig lið við áframhaldandi þróun forritsins.

Notandi ber sjálfur ALLA ábyrgð á notkun forritsins. Hugmót ehf ber enga ábyrgð á notkun eða misnotkun forritsins, né á göllum sem í því kunna að leynast. Notanda er ekki heimilt að breyta forritinu á nokkurn hátt, né nota hluta úr því í önnur forrit (e. reverse engineering).

(c) 2002-2003, Hugmót ehf. Allur réttur áskilinn.


Stillingar og valkostir

Áður en þú byrjar að nota forritið, skaltu yfirfara stillingar og valkosti og tilgreina vaktskilyrði. Hér sérðu Stillinga-síðuna og stutta skýringu á hverjum valkosti um sig:

stillingar

Sekúndur milli athugana á vaktskilyrðum (5-3600):
Hér tilgreinir þú hve reglulega á að kanna tilvist skráa skv. vaktskilyrðunum. Það getur verið á klukkutíma fresti (3600 sekúndur) og allt niður í að vera á 5 sekúndna millibili. Ef vinnslur eru þungar og þessi tími stuttur, getur vaktyfirferð dottið út. Sjálfgefið er einu sinni á 60 sekúndna fresti.

Fjöldi skráa pr. skilyrði sem unnið er með (1-100):
Veldu hve margar skrár skuli vinna með í senn fyrir hvert vaktskilyrði. Sjálfgefið er 10 skrár, en þessi stilling fer mjög eftir eðli og tíma úrvinnslunnar. Þetta er m.a. gert til að efstu vaktskilyrðin fá ekki of mikinn hluta af vinnslugetu forritsins og tölvunnar.

Vara við ef skrá er til fyrir við flutning:
Hakaðu við þennan valkost ef þú notar Flytja í safn fyrir eitthvert vaktskilyrðanna. Ef skrá er til fyrir, t.d. vegna bilana í úrvinnsluferli, varar kerfið við. Annars er skrifað yfir þá skrá sem er til fyrir.

Stærð forritaglugga þegar unnið er á skrár:
Veldu hér hvort úrvinnsluforritin eigi að birtast í forgrunni eða bakgrunni, eða þá yfirleitt. Sjálfgefið er agnarsmár í forgrunni (e. minimized). Ef þú vilt fylgjast með framvindunni, skaltu velja Venjulega stærð eða Tekur yfir allan skjáinn.

Skrá framvindu í:
Tilgreindu hér heiti textaskrár fyrir framvindu-skýrslu. Forritið skrifar þá upplýsingar um hvaða skrár fundust og hvaða úrvinnsla fór fram, ásamt dagsetningu og tíma. Þetta hentar ef þú vilt geta rakið framvinduna langt aftur í tímann. Annars birtast boðin eingöngu í skýrsluglugganum (í neðri hluta aðalgluggans).


Vaktskilyrði

Vakta vinnur eftir vaktskilyrðum sem skráð eru í gagnatöfluna Vakta.mdb. Vaktskilyrðin birtast í lista í efri hluta aðalgluggans og má breyta þeim eða bæta við eftir þörfum.

vaktskilyrði

Vaktskilyrðin samanstanda af lýsingu (t.d. Textaskrár frá Tolli), skráaheiti eða skráaramma sem fylgjast á með í svæðinu Vakta skrár (t.d. c:\data\*.txt) og upplýsingar um hvernig unnið skulið úr þeim skrám sem finnast, með því að fylla út annað eða bæði svæðin, Flytja í safn og Aðgerð (t.d. notepad.exe %FILE% /P). Ef tilgreint er skráasafn til að flytja skrána í, er það framkvæmt fyrst og aðgerðin á eftir.

Þú getur aftengt eða virkjað vaktskilyrði tímabundið með því að hægri-smella og velja Vakta þennan lið af/á. Í svæðin Bið á undan og Bið á eftir getur þú tilgreint tíma í sekúndum. Þá er hinkrað fyrir og/eða eftir vinnslu til að gefa öðrum forritum tækifæri til að ljúka sínum vinnslum áður en lengra er haldið.

Vaktlistinn er að öllu jöfnu lokaður fyrir breytingum, til að koma í veg fyrir að vaktskilyrði breytist óvart. Til að breyta færslu, skaltu smella á Upp-píluna á tólastikunni eða Plús-táknið til að bæta við nýrri færslu.


Breytur í boði

Fyrir ákall á úrvinnsluforrit eða flutning í skráasafn má nota breytur til að framkvæma ákallið með réttum færibreytum. Slíkar breytur eiga aðeins við í svæðunum Flytja í safn og Aðgerð. Eftirtaldar breytur eru í boði (dæmin miða við inntaksskrá með heitinu c:\skráasafn\undirsafn\skrá.txt):

%FILE% | Fullt skrárheiti (c:\skráasafn\undirsafn\skrá.txt)
%PATH% | Skráasafnið sem skráin er í (c:\skráasafn\undirsafn\)
%NAME% | Heiti skrárinnar sjálfrar (skrá.txt)
%BASE% | Heiti skrárinnar sjálfrar án eftirnafns (skrá)
%EXT% | Eftirnafn skrárinnar (.txt)

Þegar vaktskilyrði er búið til eða því breytt, getur þú hægri-smellt og valið breytu til að bæta við skipanalínuna.


Skrá notendanafn og leyfisnúmer

Þegar þú hefur pantað ótakmarkað notendaleyfi, þarftu einungis að skrá nafn notanda og leyfisnúmerið inn í forritið. Ekki er þörf á að setja það inn aftur. Veldu liðinn Notendaleyfi - Skrá notendanafn og leyfisnúmer á valmyndinni og þá birtist þessi mynd:

skráning

Skráðu inn nafnið og númerið (einfaldast er að afrita og líma úr staðfestingarskeytinu) og ýttu síðan á Staðfesta-takkann. Ef allt er rétt tilgreint, birtist þakkargluggi á skjánum og nafn notanda verður framvegis í efra, hægra horni forritagluggans. Auk þess eru allar notkunartakmarkanir að sjálfsögðu úr sögunni.


Uppfæra í nýjustu útgáfu

Veldu liðinn Hjálp - Uppfæra í nýjustu útgáfu á valmyndinni. Þá birtist þessi skjámynd og getur þú athugað hvort ný útgáfa sé fáanleg af forritinu. Ef svo reynist vera, er uppfærslan sótt og sett inn.

uppfærslur

Smelltu á takkann og fylgstu með þegar ný útgáfa verður sótt og sett upp á tölvunni þinni. Tölvan þín þarf að sjálfsögðu að vera tengd við Internetið þegar þessi aðgerð er framkvæmd. Uppfærslur gerast varla auðveldari!


Aðstoð á vefnum og í tölvupósti

Þú finnur ýmsar upplýsingar um notkun forritsins á vefnum www.hugmot.is/vakta

Þar eru m.a. svör við algengum spurningum, nýjar útgáfur og boðið upp á að senda inn villutilkynningar.

Aðstoð er einnig veitt gegnum netfangið vakta@hugmot.is en gera má ráð fyrir að nokkra daga taki að svara slíkum skeytum.

Skráðir notendur geta hringt í síma 562-3740 til að fá aðstoð við úrlausn vandamála. Fyrstu 5 mínúturnar eru ókeypis, en gjaldfært skv. tímataxta eftir það.


.topic 201
Fyrir ákall á úrvinnsluforrit eða flutning í skráasafn má nota breytur til að framkvæma ákallið með réttum færibreytum.  Slíkar breytur eiga aðeins við í svæðunum Flytja í safn og Aðgerð.  Eftirtaldar breytur eru í boði (dæmin miða við inntaksskrá með heitinu c:\skráasafn\undirsafn\skrá.txt):

Þegar vaktskilyrði er búið til eða því breytt, getur þú hægri-smellt og valið breytu til að bæta við skipanalínuna.